System Disruption
Incident Report for Everflow Technologies
Resolved
This incident has been resolved.
Posted Aug 28, 2020 - 15:32 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 28, 2020 - 15:26 UTC
Investigating
We are currently investigating this issue.
Posted Aug 28, 2020 - 14:54 UTC
This incident affected: Everflow Web Application, Everflow API, Click/Impression Processing, and Conversion Processing.