Issue with a small portion of incoming traffic
Incident Report for Everflow Technologies
Resolved
The incident has been resolved
Posted Mar 26, 2020 - 16:05 UTC
Investigating
A small portion of all incoming traffic is being dropped with error code 502, this affect clicks, conversions, api requests and our UI.

We are currently working with Google to resolve the issue.
Posted Mar 26, 2020 - 15:58 UTC
This incident affected: Everflow Web Application, Everflow API, Click/Impression Processing, and Conversion Processing.