Unexpected System Disruption

Incident Report for Everflow Technologies

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 19:21 UTC

Update

Google Cloud Platform, which Everflow is built on, experienced a major service outage which affected Everflow's platform : https://status.cloud.google.com/incidents/ow5i3PPK96RduMcb1SsW

We are still monitoring our systems and investigating but all services are currently back online.
Posted Jun 12, 2025 - 19:20 UTC

Update

Google Cloud Platform, which Everflow is built on, experienced a major service outage which affected Everflow's platform : https://status.cloud.google.com/incidents/ow5i3PPK96RduMcb1SsW

We are investigating the issue
Posted Jun 12, 2025 - 18:29 UTC

Investigating

We are investigating an issue that is affecting Everflow's systems. The underlying issues seems to come from the Google Cloud Platform. More details to come
Posted Jun 12, 2025 - 17:50 UTC
This incident affected: Everflow Web Application and Everflow API.