Platform Outage
Incident Report for Everflow Technologies
Resolved
Google Cloud Power Outage

Following a power outage inside one of Google Cloud datacenter, the Everflow platform was down between 12:55pm UTC and 4:20pm UTC. During that time, all Everflow services were impacted.

We apologize for any inconvenience caused by these incidents and rest assured we will be investigating to make sure these don't happen again. Please contact our support team @ https://help.everflow.io/ if you have any specific questions regarding these incidents.

*UPDATE*
Google released a post-mortem regarding the outage they occurred on June 29th 2020 in their us-east1 region: https://status.cloud.google.com/incident/cloud-networking/20005
Posted Jun 29, 2020 - 17:00 UTC